RegisterSearchFAQMemberlistUsergroupsLog in
Reply to topic Page 55 of 56
Goto page Previous  1, 2, 3 ... , 54, 55, 56  Next
98 GMC Twin Turbo with 12200411 PCM--- It's Alive
Author Message
Reply with quote
Post  
Thanks Jeff

I didn't know GM out the 5.0 in the express vans. My code reader said 2001 express 2500 5.0. I'm going to run the vin to double check.

View user's profile Send private message
Reply with quote
Post  
Hi my name is Derrick, first post here so I wanted to introduce myself and say hi
and I'm glad I found this forum!

I've got a couple questions I'd like to see what everyone's thoughts are.
I've got a 1998 ECSB 2wd 1500 Silverado that I picked up for cheap with a hurt engine (305) in it. I have a '99 2500 express van with a 350 & 4L80E I'm wanting to put in my '98 pickup. I also have a 0411 ecm and wiring harness off an '01 3500 express that had a 350 and 4L80E.

What I'm wondering is, If I use the 0411 ecm & harness off the 3500 van can I pull off the ecm swap without having to re-wire anything?
Also has anyone else swapped from the 4L60E to the 4L80E in a 2wd pickup? I'm wondering if it's a direct plug and play swap other than changing the yoke out or if there's more to it than that.

Any help much appreciated!

View user's profile Send private message
Reply with quote
Post  
The Van harness is not going to be a plug and play. It would be MUCH easier to repin the PCM connectors of your 98 for the 0411 PCM. The 4L80 will need the crossmember moved back a bit. I "think" 3 of the 4 holes line up. You will need the matching slip yoke. There is a slight repin of the PCM connector and trans connector and adding a front speed sensor connector.

Jeff

View user's profile Send private message
Reply with quote
Post  
Repinning at the round trans plug isn't that hard to do either. The driveshaft will have to be shortened approximately 2 inches as well. The flexplate will have to be replaced with a 4L80E flexplate.

View user's profile Send private message Send e-mail
Reply with quote
Post  
Ok thanks guys for the replies. Im fairly mechanically savvy so i don't think it's something i can't tackle over time.
I had the harness & '99 van because i had originally considered dropping the 350 into my 03 rcsb v6 and i decided that was more trouble than it's worth. So I found this truck for cheap and picked it up.

Lextech I've read some previous posts from you indicating you have a wiring pinout for this swap? If i pm'd you my email would you be so kind as to send that my way?

View user's profile Send private message
Reply with quote
Post  
Wonder what the difference is between the '01 L31 harness and the '99 engine?

View user's profile Send private message
Reply with quote
Post  
I don't know what the difference is between a 99 and 01 harness. PM me your name and e-mail address and I will send you the wiring file.

Jeff

View user's profile Send private message
Reply with quote
Post  
PM sent.

View user's profile Send private message
Reply with quote
Post 411 installed 
I just installed my 411 yesterday. Not too bad at all. I try to start it now and it starts but immediately shuts off. Does this mean I need to do the crank relearn or should I start looking for something I wired wrong. Thanks for anyones help

View user's profile Send private message
Reply with quote
Post  
I'm not and expert on this, but it could be Vehicle Anti-Theft.

Needs to be deactivated in the PCM

View user's profile Send private message
Reply with quote
Post  
Okay. Im trying to check all of that out now. I got a flashscan so I could try to do the tune myself from a base van tune. Still trying to figure out how to use it. Does that sound like what the truck would do if the vats was still on?

View user's profile Send private message
Reply with quote
Post  
Yes, I haven't played with EFi live for a long time but I believe that could be the reason.

http://www.pacificp.com/forum/viewtopic.php?t=6162&view=previous&sid=d84529dc699690af000b763d6060f371

View user's profile Send private message
Reply with quote
Post  
Pretty easy to turn off in the tune to. You got the flash scan that's the hardest part

View user's profile Send private message
Reply with quote
Post  
Just got it started. Kind of figuring out how to use this flashscan. Now I need to do a relearn. Is there a write up on here on how to do that

View user's profile Send private message
Reply with quote
Post  
It's again been a long time, but the 411 has finally been installed and dyno'd !!!

Put down 376.8 to the wheels, and drivability is WAY better as well. I don't know how to post pics, so I'l ask James B now.[/img]

View user's profile Send private message
Reply with quote
Post  
Vortec Stroker wrote:
It's again been a long time, but the 411 has finally been installed and dyno'd !!!

Put down 376.8 to the wheels, and drivability is WAY better as well. I don't know how to post pics, so I'l ask James B now.[/img]

Hey Frank, nice to see you pop in with some great news. Those are some potent numbers.
Still on the stock poppets? What kind of fuel pressure are you running? Is this the same dyno that you ran your old 330rwhp numbers on?
Still on the same 383?

Take care man
peace
Hog

View user's profile Send private message
Reply with quote
Post  
This is Vortec Stroker (Adam) other login was not working so I had to make a new one.

Still on the stock poppets which are now fully maxed out.

Fast305 helped and posted pics of the setup on the FSC forum if anyone is interested.

I can email someone the pics and video if they can help post them on here too.

View user's profile Send private message
Reply with quote
Post  
Vortec 383 wrote:
This is Vortec Stroker (Adam) other login was not working so I had to make a new one.

Still on the stock poppets which are now fully maxed out.

Fast305 helped and posted pics of the setup on the FSC forum if anyone is interested.

I can email someone the pics and video if they can help post them on here too.

Sorry Adam, right truck, wrong 1st name.

peace
Hog

View user's profile Send private message
Reply with quote
Post You're killing me, Smalls! 
0411 installed, again. Runs like shit! Black Bear tune, HT383e, marine intake. The first attempt was a spare Escalade harness converted for 0411. That one had issues (later found to be bad brake light switch, but also noticed I forgot to split the orange ECM power), so I returned to the stock harness. Now, modified the stock harness for 0411 and the engine stumbles, badly! Rough idle at start up. I have EFILive, but I seem to have no idea what I'm doing.
I tried to do a CASE relearn but that didn't seem to work. Please help!

UPDATE:
P0200, P0300 codes. Also MIL is blinking under load. Catastrophic failure!?!?!?!?!?!?!

I'm thinking about returning to the black box again. Eliminate the harness, again, and either its the 0411 or the tune. Anyone want to take a look?

UPDATE again:
Wow, no posts or responses on this thread in a while. Well, I'm an idiot. It helps to kick the family out of the house when your pining the new ecm connection. Had one of the fuel injection pins located on an pin. D'oh! Maybe I should have had less beer while doing it. Still have P017* something codes for rich fuel in both banks. Any suggestions?

View user's profile Send private message
Reply with quote
Post  
I swapped a 1999 L29/4L80E into my 72 Chevelle wagon. Currently the black box from a 96 truck and a Painless harness are installed and the PCM only runs the engine and transmission. The box has had the security stuff and rear O2 sensors removed, not sure what else. I bought it as a take out of another car when that owner did an LS swap. The dyno sheet showed it making 320 hp and 440 ft lbs of torque to the wheels. The engine has had a cam change and had 17lb injectors in it when I got it that have been upgraded to 30lb but has not been started since the upgrade. It would not idle unless the throttle is feathered for a few seconds on start up, I would like to get it to start and run like it should. Other than that it runs well but from reading the 55 pages in this thread it appears it could run better with the 0411 PCM. Some other changes I made were swapping to adjustable rocker arms, fixing a vacuum leak in the upper plenum, found the cam sensor had been installed 35° off, moved the MAF away from the throttle body (it was only 2" away), removal of the EGR and canister purge bosses on the plenum and added a 3 pin oil pressure sensor. I would also like to control the cooling fans through a computer rather than just a temp sensor in the head. And eventually set it up for a lean cruise. The car will be used for daily driving and vacation trips with a few trips to test n tune just to have fun.
The car is down for paint and body so while it is in paint jail on a roller frame I have some time to work on the conversion. The frame that will be used has all the suspension and steering rebuilt, the engine and transmission installed so it can be started although not driven. A PCM has been purchased, it came from a 2003 Express 3500 with an L31/4L80E drivetrain. The vehicle was listed on the door tag as a BUS- NOT SCHOOL BUS and had 4 rows of seats behind the driver. I also have one from an 01 Blazer 4.3L/4L60E.
I have learned from reading here that I will need the pnp switch and need to move a lot of wires from the Painless harness to the 80 pin connectors. Have emailed Painless hoping to get a pin out. If they do not respond I do have a 96 truck GM service manual that has the stock pin out. It appears the Painless harness used the exact same wire colors as GM did but all would have to be verified from PCM to the sensors. With the body off the frame running any extra wires will be a lot easier.
My biggest concern is getting a base program and actually learning how to use tuning software. Will the current CKP work with the 0411 PCM?
I'm 66 and have been building hot rods since the late 60's. Worked for years as a GM factory trained tech but that was during the Computer Command Control era and a little bit of OBD I. I can use a scanner and wiring does not intimidate me. Hoping the experienced members here can guide me through the conversion. Thanks.

View user's profile Send private message
Display posts from previous:
Reply to topic Page 55 of 56
Goto page Previous  1, 2, 3 ... , 54, 55, 56  Next
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum