97 vortec 454 dropping cyls on dyno (misfires at 3400rpm)

Performance modifications, tips & tricks

Moderators: Eric@PPE, James B., flyingpolarbear, Dev

Post Reply
Greg Peter
Posts: 3
Joined: Sun Jan 14, 2018 1:03 pm
Location: Alberta

97 vortec 454 dropping cyls on dyno (misfires at 3400rpm)

Post by Greg Peter »

Hi, I'm working on a 97 vortec 454 that I have rebuilt, all stock including new exhaust seats, but I put a normal comp cams flat tappet cam, comp adj rockers, proper length pushrods, and Edelbrock air gap intake with 800 Edelbrock carb, and a normal hei. running it on the dyno it looses random cylinders (at 3400 rpm) but always number 7. things I have aleady tried: 3 different ign systems, 3 different carbs, heads off twice to inspect (all good), 3 sets spark plugs, different coil, wires and cap, installed a stock hyd roller cam (proper pushrods), tried a dual 4 bbl intake, this engine produces good leakdown results, pulled #7 piston to ck rings etc, but it always falls on it's face at 3400 rpm with random cyl misfires, typically 1,2,5 and always 7. It runs great during warmup, idles perfect, pulls nicely to 2500 (inertia dyno). Has anyone seen anything like this? for now I took it off the dyno, put it in a corner and kicked it (hurt my foot) I want to try some 781 heads but that's in the future. Thanks.

Speeder
Posts: 10776
Joined: Fri Apr 30, 1999 9:12 pm
Location: 2015 Tahoe 2WD 5.3L 6L80E, 2008 Colorado work beater, 2003 Dodge Dakota pro-touring project

Post by Speeder »

I know you said multiple ignition, does this include a new distributor? My thinking is the pickup coil might be acting up. Another thought, check all the major grounds. There should be a strap engine to block, engine to frame, engine to battery. Third thought, clogged fuel filter. Fourth thought, failing fuel pump. Either the filter or pump may be capable of fueling the engine to 3300RPM, but can't manage more than this. Good luck, sounds like a difficult one.

1999 Tahoe 4x4
Posts: 764
Joined: Sat Dec 15, 2007 2:00 pm
Location: Torrance, CA

Post by 1999 Tahoe 4x4 »

Have you checked the teeth of your distributor for uneven wear all around?

Some people were reporting similar issues from that.

ThunderTT
Posts: 2845
Joined: Sun Apr 03, 2005 10:27 pm
Location: 97 ECSB 2WD 98 CCLB 2WD 00 Escalade 4x4

Post by ThunderTT »

is it dropping or floating? i saw no mention of better springs - stockers are extremely weak

TRANS03
Posts: 37
Joined: Wed Apr 01, 2009 12:36 pm
Location: St Louis, Missouri

Post by TRANS03 »

I had the same problem with a 454 I rebuilt. I fought it for weeks. It ended up being valve springs as mentioned above. They were new but had been sitting for years. For some reason the were really weak. New springs and she ran awesome.

Greg Peter
Posts: 3
Joined: Sun Jan 14, 2018 1:03 pm
Location: Alberta

Post by Greg Peter »

Update on the Vortec 454 dropping cylinders, thanks for all the reply's, I checked every single suggestion, especially the valve springs. Also a set of iridium spark plugs. I put a set of normal type [combustion chamber / intake port] cylinder heads on and it is fixed. The Vortec heads are a high swirl combustion chamber, right? Could the flame front be blown out above 3400 rpm? As it was typically dropping outside cylinders, could port velocity on the outside cylinders [1,2,7,8] be different than the inside cylinders? Now what do I do with the Vortec heads.... Thanks for all the suggestions.

James B.
Moderator
Posts: 2823
Joined: Thu Apr 03, 1997 4:00 pm
Location: '98GMT400, '98GMT410, '99GMT420, '00GMT420

Post by James B. »

I've seen an L31 behave exactly like this due to a faulty crank position sensor.

Post Reply