RegisterSearchFAQMemberlistUsergroupsLog in
Reply to topic Page 2 of 2
Goto page Previous  1, 2
New Duramax
Author Message
Reply with quote
Post  
So after some time of owning this 2014 Duramax quad cab long box 4x4, I love it. Made one big change to it so far, removed the 35gallon tank and had a 61 gallon tank installed in its place. Love the range I get now pulling the 5th wheel, about 750 miles. Yes, the addition of DEF fluid is an absolute PITA with the opening up on the fire wall under the hood. There is no gauge saying how much is in it so you have to listen closely as your adding the fluid from a 9.5L jug, but most times, it just over flows...
One thing that bothers me is that when I first start the truck lets say in the morning, the charging system meter on the dash says I'm below 12V and stays that ways for maybe a mile or 2 then comes up to about 14 and stays there. I can see its low when using the wipers (they run slower). I know my first step should be to check it with a DMM or load test the batteries. Could this indicate a "about to fail alternator" of just the computer being so to respond to the gauges.

Short of that, I love this truck and its ability to tow my 38' 15,000lb 5th wheel with very little effort in any traffic or road design, hills etc.
[/img]

View user's profile Send private message
Display posts from previous:
Reply to topic Page 2 of 2
Goto page Previous  1, 2
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum