Sticking Valves Vortec Heads?

Performance modifications, tips & tricks

Moderators: Eric@PPE, James B., flyingpolarbear, Dev

Speeder
Posts: 10777
Joined: Fri Apr 30, 1999 9:12 pm
Location: 2015 Tahoe 2WD 5.3L 6L80E, 2008 Colorado work beater, 2003 Dodge Dakota pro-touring project

Post by Speeder »

I think you have a problem with your #5 injector, not a fuel pump problem. If only #5 reports the problem, only under load, and it's happened with two different fuel pumps, then I think one of your #5 injector's holes has debris in it. A fresh fuel pump pushes enough fuel to "clear" the problem, but as soon as the pump wears a bit and pressure drops a pound, it's not quite pushing enough fuel out anymore, so it would start showing up under low speed/high load conditions like driving up a hill. Doesn't have to be a big piece of debris, just enough to plug one of the 4-6 holes in the injector. Since I'm sure you tried cleaner, it must be something hard, like a bit of quartz from sand, or a tiny metal shaving.

Just a thought. I could be wrong, it's happened once or twice before. :D

1999 Tahoe 4x4
Posts: 764
Joined: Sat Dec 15, 2007 2:00 pm
Location: Torrance, CA

Post by 1999 Tahoe 4x4 »

Thanks Speeder, I agree with your analysis, but somehow it did not work out that way.

Initially I was trying to fix my intermittent start issue and initially I have changed the fuel pressure regulator and 2x poppet injectors #5 and #7. The inside of the manifold in their respective area was sparkling clean, while all other areas were full of charcoal.

Subsequent to changing the above parts, intermittent starting remained an issue and upon a subsequent test drive even my earlier symptom #5 cylinder misfire showed up.

So not knowing what else, I changed the fuel pump and a few weeks later the ignition switch (at this point I positively found the switch faulty).

From here on I had more no #5 cylinder misfire.

Post Reply