RegisterSearchFAQMemberlistUsergroupsLog in
Reply to topic Page 1 of 1
Help with lightly modified L31-R
Author Message
Reply with quote
Post Help with lightly modified L31-R 
Hello all, looking for some help. I have a 97 Chevy K1500 Suburban w/ a 6" lift. This summer I installed a L31-R crate engine. It has been modified with Chevrolet Performance Hydraulic Roller Camshafts 12677151 (Duration at .050 in. 215/223, Lift .473/.473), Doug Thorley Tri-Y Headers and the upgraded MPFI Spider.

I just had a new exhaust installed with 2 - 2-1/2" highflow Catalytic Converters into a 2-1/2" Y-Pipe into 3" Turbo Muffler and 3" Tail Pipe.

It's running on the stock computer badly. and throwing the following codes:


Current Fault Log
------------------
P0101: Mass or Volume Air Flow Circuit Range/Performance Problem
P0300: Random/Multiple Cylinder Misfire Detected

Pending Fault Log
------------------
P0108: Manifold Absolute Pressure/Barometric Pressure Circuit High Input
P0134: O2 Sensor Circuit No Activity Detected (Bank 1 Sensor 1)
P0154: O2 Sensor Circuit No Activity Detected (Bank 2 Sensor 1)


So, I knew the changes would be allot for the stock tune but it runs pretty badly with a misfire and very poor idle.

I have everythhing to do the 411 Swap, but thought it might be wiser to get it running on the stock computer before making the big change to the 411.

Maybe that was not the best choice.

For some reason the muffler shop did not plug in my new 02 sensors and only installed the 2 front ones stating "the back 2 don't tell the computer anything."

Once it stops snowing I'll get under there and plug in the front 2 sensor and hopefully that will clear at least 2 codes.


So my question you guys who have much more experience with this than I:

Will the stock computer be able to handle the changes and increased air flow of the engine, or should I send out my 411 PCM and get a tune on it based on the changes I've made?

This my first attempted at a mild upgrade of a modern engine, have much more exp with carbed engines.


Thanks in advance for the help.

View user's profile Send private message
Reply with quote
Post  
More info

Things replaced with new build:

distributor
AC Delco cap & rotor
Ignition module
crank sensor
cam sensor
ac delco plugs
Summit 8mm wires
new MPFI Spider`

Also Cam Retard set to .02 at 11-1200 rpm

View user's profile Send private message
Reply with quote
Post  
engine will probably run on stock tune, just not very well....misfire codes probably associated with cam, not sure about MAF, check for leaks in intake tube.

View user's profile Send private message
Reply with quote
Post  
probably needs a relearn since the disty was changed.

View user's profile Send private message
Reply with quote
Post  
After hooking up 02 sensors and fixing 2 wires not fully seated on spark plugs, I'm down to one code P0101 Mass Air Performance. I started looking for vacuum leaks but got rained out. Will tray again tomorrow. Will also look into testing MAP Sensor.

Thanks for the help so far, will report back.

View user's profile Send private message
Reply with quote
Post  
davkenrem wrote:
After hooking up 02 sensors and fixing 2 wires not fully seated on spark plugs, I'm down to one code P0101 Mass Air Performance. I started looking for vacuum leaks but got rained out. Will tray again tomorrow. Will also look into testing MAP Sensor.

Thanks for the help so far, will report back.


Great work! Sometimes it's aggravating but worth it, to go back over everything just to be sure.

View user's profile Send private message
Display posts from previous:
Reply to topic Page 1 of 1
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum