RegisterSearchFAQMemberlistUsergroupsLog in
Reply to topic Page 1 of 1
1996 K1500 really odd no start. Ignition
Author Message
Reply with quote
Post 1996 K1500 really odd no start. Ignition 
Hey guys. It's been the better part of a decade since I was active here. Hope all is well.

Recap: 1996 Chevy k1500 with 0411 pcm and mpfi. Dug the old girl out of the garage and have been running her. Went to start today and no dice.

Intermittent spark, coil wire shows spark exactly as it should when disconnected from the distributor. When you reconnect the coil wire the timing light shows intermittent spark at the coil wire.

Edit: more info. (was having trouble posting from my phone)

The truck cranks and gets plenty of fuel. Will fire every once in a while but seems to fire only one cylinder. When using a timing light on any given spark plug wire the spark is very choppy and intermittent.

I've gone over everything.
-Fuel pressure is good.
-New ignition module. No Change.
-New crank sensor. No Change.
-New cam sensor. No Change.
-New coil. No change.
-Distributor gear has no excess play.
-Cap and rotor look good.

At this point in the trouble shooting I discovered that as stated above:
If I disconnect the coil wire from the distributor and let it spark to a ground point on the block it fires perfectly(but maybe appears weak).
With the coil wire attached to the distributor, and testing with a timing light on the coil wire, the spark becomes intermittent.

I'm down to it being a problem with: coil wire, cap or rotor.

My thought is that there is enough power to overcome the resistance of ONLY the coil wire->ground, but as soon as you ask that same spark to travel the coil wire->cap->rotor->plug wire->plug->ground it cant make the journey.


EDIT: more information: Thinking that perhaps there was a potential wiring issue to the coil or module I direct connected the pink wire at the coil and module to 12V+ and the blk/wht wire at the module to Ground. No change.

Furthermore, the engine fires as soon as you quit cranking. When observing the coil wire spark, at the moment that you quit cranking, the instantaneous spark is much more powerful. Blue lightning instead of orange/blue fire. I'm thinking this is due to the fact that you are no longer drawing on the available battery power and so there is a much stronger spark available. Which really only applies if it is indicating perhaps a failing coil wire? I've just never seen these particular symptoms before.

Side note: all tests have been completed with a battery charger attached so to not allow a low voltage situation adding to the symptoms.

View user's profile Send private message Send e-mail
Reply with quote
Post  
My thought, voltage is not amperage, and a starter takes an enormous amount of power off. If the battery has a cell crapping out, a charger wouldn't necessarily overcome it. Try it with a new battery. If you have another car, swap for a test.

A coil is a wear item, and not too expensive. Same with plugs and wires.

View user's profile Send private message Send e-mail
Reply with quote
Post  
Good point on voltage vs amperage. Sorry for the misstatement.

The coil is new and we swapped plugs and wires out of another truck with no success.

The battery never crossed my mind because of how strongly it cranks over. I'll swap in a different battery and try it.

Thanks

View user's profile Send private message Send e-mail
Display posts from previous:
Reply to topic Page 1 of 1
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum