RegisterSearchFAQMemberlistUsergroupsLog in
Reply to topic Page 1 of 1
2000 Escalade starting issues
Author Message
Reply with quote
Post 2000 Escalade starting issues 
hi guys...

now that im finished with my move back to TX, im starting to get some issues ironed out....

heres a recap of the Escalade blues....

sat for a couple years, started it to move it onto the trailer, ran like crap, but ran.... came out the next day and wouldnt start.... checked FP and it was at 20psi....

dropped the tank, and noticed the gas (even with Stabil) had turned not only to varnish, but acidic.... the pump was corroded and the filter sock was disolved - so i made the conclusion that what was left of the sock may have been sucked up taking out pretty much everything.... so i loaded it on the trailer and put it on the back burner....

once i had time, i dropped the tank again - washed it out completely - got a whole new pump assembly, new filter, blew out the lines for any possible trash remaining, then focused on the engine side....

i ordered a new upper intake as well as the upgraded injectors and got everything buttoned up, only to find that it still would not start.....

fuel pressure was good - it was starting, then shut off right away - i had someone start it while i poured gas down it - and it would stay running - which told me the injectors were being shut off - AKA, in security protection from the awesomely stupid passlock 2 system.....

tried doing the resistor bypass (as i have literally done over 1000 times when i was doing my car audio gig) only to find out, i could not get a resistance reading....

ok - so, for any of you guys wondering, the passlock module is under the dash and physically under the pocket/CD player location, and not real fun to get to....

once i got it out, i took it apart and found a blown capacitor, with the usual black checking around it from when it popped.....

grabbed one i had from one of the many dashes i have - and installed it, but in my research i came across a company called new rockies, they do a total passlock bypass with one of their modules - it is complete elimination of the passlock system.....

so - that brings me to today, i just got the module yesterday, and just hooked it up - only a few wires....

i am going through the 30 minute learning process, and then i get to see if it works....

will give an update later, i hope it works, if not i need to figure out another alternative.....

if you guys want to check them out - they are at http://newrockies.com/passlock-bypass-2/

View user's profile Send private message Send e-mail
Reply with quote
Post  
Shut off or plugged up? If you were able to start it and it ran like crap, all that crap you cleaned out made it into, and through, your injectors. Varnish likes to glue things shut when it runs through. You might get away with a professional cleaning but I think you're going to need new injectors. If your passlock fix doesn't get it, look into checking the injectors out.

View user's profile Send private message Send e-mail
Reply with quote
Post  
Read his post he has replaced everything including the injectors!

View user's profile Send private message
Reply with quote
Post  
Then I stand corrected, missed that the injectors were replaced.

View user's profile Send private message Send e-mail
Reply with quote
Post  
I thought I was interested. Then WOW. $279 for the kit.

So OK, after the shock is gone: please keep us updated.

View user's profile Send private message
Reply with quote
Post  
What if you just tuned the pass lock out of the ECM and be done with it?

View user's profile Send private message
Reply with quote
Post  
stroker97k1500 wrote:
What if you just tuned the pass lock out of the ECM and be done with it?
Would the EFI-Live or HP-Tuners be able to do that? For sure?

If so, that would be the "final straw" for me to buy. I would probably go with HP-Tuners since I recently bought another vehicle (non-GM) and support for that plattform is HP-Tuners.

View user's profile Send private message
Reply with quote
Post  
ok, sorry for the delay - works been crazy.......

the truck RUNS....

and their tech support is top notch....

at first it didnt work - and long story short, the module busted a capacitor inside the unit itself (the factory passlock module), so i needed another one, luckily i have a few dashboards laying around and grabbed one, lol

got it in, followed the relearn and popped off, now its running like new (as it should, i have less than 100 miles on the motor since the rebuild years ago and a whole new fuel system with upgraded injectors)

yes, at $279, it is on the high side, but its a complete bypass, and can be moved from vehicle to vehicle returning it back to stock...

i am happy with it, as far as tuning it out - pretty sure you can, but i have not got my TC software on this new laptop, but i did order the USB adapter that just got here today, so i will get back to tuning again and double check....

next on the to-do list is getting a fuel pump and filter in big red and see where im at.....

View user's profile Send private message Send e-mail
Display posts from previous:
Reply to topic Page 1 of 1
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum