RegisterSearchFAQMemberlistUsergroupsLog in
Reply to topic Page 1 of 1
Whipple belt problems
Author Message
Reply with quote
Post Whipple belt problems 
So I'm having belt issues with my Whipple on my 383, 1.6l compressor with a 2 5/16" pulley. The problem i have is a squeaky belt. Squeak seems to be coming from tensioner alternator area, both are new. I had this problem years ago so I installed a gatorback belt and the problem has been gone. Well the gatorback finally wore out so I put a gates belt on and the noise returns. Does anyone have any ideas or suggestions of what I should look for?

View user's profile Send private message
Reply with quote
Post  
I was looking through some serp. belt books with a buddy and there are some belts that are specifically designed for supercharger use. They were quite expensive, compared to regular serpentine belts. Maybe search through some OEM supercharged units like the 3.8 s/c and see what comes up for supercharger specific belts? IIRC the 3.8 s/c uses the same belt for the blower as well as the accessories. I'm pretty sure that the GEN 4 LS9/LSA and the GEN 5 LT4 use a separate blower belt for their TVS blowers.

There are also spray on and solid type belt dressings that may help?????

peace
Hog

View user's profile Send private message
Reply with quote
Post  
gatorback belt hehe
Done

View user's profile Send private message
Reply with quote
Post  
I work in a machine shop where the metal walking surface gets coated with coolant and oil.

The antislip solution is to sand blast the surface.

So, maybe lightly sandblasting the pulleys might help the grip hopefully not eating the belt.

View user's profile Send private message
Reply with quote
Post  
I have ordered another gatorback belt just waiting for it to arrive.

Haven't tried any belt dressing, I have not had good experiences with it in the past. It usually seems to make a problem worse and it is extremely hard to remove from the pulleys and makes a mess. I did try the old time trick of a bar of soap but that only quiets it momentarily.

All the 3.8 engines I have worked on ran a separate belt. I do not believe there is an application that would have anything long enough. The belt i am using is 110 inches long.

View user's profile Send private message
Reply with quote
Post  
Whipped383 wrote:
I have ordered another gatorback belt just waiting for it to arrive.

Haven't tried any belt dressing, I have not had good experiences with it in the past. It usually seems to make a problem worse and it is extremely hard to remove from the pulleys and makes a mess. I did try the old time trick of a bar of soap but that only quiets it momentarily.

All the 3.8 engines I have worked on ran a separate belt. I do not believe there is an application that would have anything long enough. The belt i am using is 110 inches long.

They were separate too, ok, my mistake.

The dressings can make a mess, esp the sprays, a little goes a long way.

110 inches helps, at least with the part number of the belt.

peace
Hog

View user's profile Send private message
Reply with quote
Post  
My Whipple pulley never lined up exactly with the rest of the serpentine system. I ended up using a spacer between the pulley and supercharger hub. Check your alignment with a long straight-edge on the crank. Wrap a belt around the crank and measure the distance between the straight-edge and the edge of the belt. Wrap the supercharger and compare that distance. I'm going to wager it doesn't match.

View user's profile Send private message
Reply with quote
Post  
...continued....

I have a lot of experience with belts. It used to shread a $40 belt 2-3 times a year. The Goodyear Gatorbacks were the stretchiest and most likely to snap. Dayco PolyCogs held up the best for me. There's a Gates Greenstripe on the market now that seems popular with serpentine blower owners but I don't have any first-hand experience with them.

View user's profile Send private message
Reply with quote
Post  
I'll check pulley alignment, I just assumed it wasn't an issue since I never have any wierd wear patterns on the belt. Heck the old gatorback was a couple years old but yeah it had stretched some.

I am noticing now that when I let off the throttle quickly WOT I hear a belt chirp. So definitely have some slipping

View user's profile Send private message
Reply with quote
Post  
That chirp when you let off is the belt contacting the tensioner housing. Reverse-torque on the belt causes the tensioner to nearly bottom out. It is probably intentional that the belt geometry cannot fully bottom out the tensioner, because if it could the little limiting tab would easliy be snapped off by the tremendous force. The's not much you can do about it. Many years ago I had the idea of blower and alternator pulley with one-way clutches in them to prevent reverse torque on the belt. They're actually available now and I'm sure they work great, at least they did in my head 15 years ago.

View user's profile Send private message
Reply with quote
Post  
James B. wrote:
Many years ago I had the idea of blower and alternator pulley with one-way clutches in them to prevent reverse torque on the belt. They're actually available now and I'm sure they work great, at least they did in my head 15 years ago.


That would be sweet



View user's profile Send private message
Display posts from previous:
Reply to topic Page 1 of 1
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum